{"action":"Upgrade django to 1.4.21 or later.","affected":[{"fixed":"1.4.21","introduced":"0"},{"fixed":"1.7.9","introduced":"1.5"},{"fixed":"1.8.3","introduced":"1.8"}],"component":"django","cve_ids":["CVE-2015-5144"],"ecosystem":"PyPI","epss":0.03168,"exploited":false,"fixed_versions":["1.4.21","1.7.9","1.8.3"],"ghsa_id":"GHSA-q5qw-4364-5hhm","id":"tcs_01M5KG6HX0Z0JZZ7ZPQFFCN5FB","modified_at":"2026-06-10T17:00:55.930225660Z","published_at":"2015-07-14T17:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2015-10","http://www.ubuntu.com/usn/USN-2671-1","http://www.debian.org/security/2015/dsa-3305","https://www.djangoproject.com/weblog/2015/jul/08/security-releases/","http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html","http://www.securityfocus.com/bid/75665","https://security.gentoo.org/glsa/201510-06","http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172084.html","http://lists.opensuse.org/opensuse-updates/2015-10/msg00046.html","http://lists.opensuse.org/opensuse-updates/2015-10/msg00043.html","http://www.securitytracker.com/id/1032820","https://github.com/advisories/GHSA-q5qw-4364-5hhm"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2015-10","url":"https://osv.dev/vulnerability/PYSEC-2015-10"}],"summary":"Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows remote attackers to inject arbitrary headers and conduct HTTP r"}