{"action":"Upgrade github.com/charmbracelet/soft-serve to 0.8.2 or later.","affected":[{"fixed":"0.8.2","introduced":"0"}],"component":"github.com/charmbracelet/soft-serve","cve_ids":["CVE-2025-22130"],"ecosystem":"Go","epss":0.00698,"exploited":false,"fixed_versions":["0.8.2"],"ghsa_id":"GHSA-j4jw-m6xr-fv6c","id":"tcs_01M5KG6K32S5VM8YEB9Y5A5NT4","modified_at":"2026-03-03T04:57:09.409725Z","published_at":"2025-01-08T19:19:42Z","references":["https://osv.dev/vulnerability/GO-2025-3374","https://github.com/charmbracelet/soft-serve/security/advisories/GHSA-j4jw-m6xr-fv6c","https://github.com/charmbracelet/soft-serve/commit/a8d1bf3f9349c138383b65079b7b8ad97fff78f4","https://github.com/charmbracelet/soft-serve/releases/tag/v0.8.2"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GO-2025-3374","url":"https://osv.dev/vulnerability/GO-2025-3374"},{"source":"nvd","source_id":"CVE-2025-22130","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-22130"}],"summary":"Soft Serve vulnerable to path traversal attacks in github.com/charmbracelet/soft-serve"}