{"action":"Upgrade django to 1.4.22 or later.","affected":[{"fixed":"1.4.22","introduced":"1.4"},{"fixed":"1.7.10","introduced":"1.7"},{"fixed":"1.8.4","introduced":"1.8"}],"component":"django","cve_ids":["CVE-2015-5963"],"ecosystem":"PyPI","epss":0.05206,"exploited":false,"fixed_versions":["1.8.4","1.7.10","1.4.22"],"ghsa_id":"GHSA-pgxh-wfw4-jx2v","id":"tcs_01M5KG6M91YE2BP25MYS953P1G","modified_at":"2026-06-10T17:00:58.840111987Z","published_at":"2015-08-24T14:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2015-22","https://www.djangoproject.com/weblog/2015/aug/18/security-releases/","http://www.ubuntu.com/usn/USN-2720-1","http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html","http://www.securityfocus.com/bid/76428","http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172084.html","http://rhn.redhat.com/errata/RHSA-2015-1894.html","http://rhn.redhat.com/errata/RHSA-2015-1767.html","http://rhn.redhat.com/errata/RHSA-2015-1766.html","http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html","http://lists.opensuse.org/opensuse-updates/2015-09/msg00026.html","http://www.securitytracker.com/id/1033318","http://www.debian.org/security/2015/dsa-3338","https://access.redhat.com/errata/RHSA-2015:1876","https://github.com/advisories/GHSA-pgxh-wfw4-jx2v"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2015-22","url":"https://osv.dev/vulnerability/PYSEC-2015-22"}],"summary":"contrib.sessions.middleware.SessionMiddleware in Django 1.8.x before 1.8.4, 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions allows remote attackers to cause a denial of service ("}