{"action":"Upgrade notebook to 4.0.5 or later.","affected":[{"fixed":"4.0.5","introduced":"4.0.0"}],"component":"notebook","cve_ids":["CVE-2015-7337"],"ecosystem":"PyPI","epss":0.02487,"exploited":false,"fixed_versions":["4.0.5"],"ghsa_id":"GHSA-92mr-v722-f48m","id":"tcs_01M5KG6N4P5MGGKSP2Q5M69911","modified_at":"2023-11-08T03:57:59.998735Z","published_at":"2015-09-29T19:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2015-27","https://github.com/jupyter/notebook/commit/9e63dd89b603dfbe3a7e774d8a962ee0fa30c0b5","https://github.com/ipython/ipython/commit/0a8096adf165e2465550bd5893d7e352544e5967","http://seclists.org/oss-sec/2015/q3/558","http://seclists.org/oss-sec/2015/q3/634","http://lists.fedoraproject.org/pipermail/package-announce/2015-September/167670.html","https://bugzilla.redhat.com/show_bug.cgi?id=1264067","https://security.gentoo.org/glsa/201512-02"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2015-27","url":"https://osv.dev/vulnerability/PYSEC-2015-27"}],"summary":"The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/"}