{"action":"Upgrade dulwich to 0.9.9 or later.","affected":[{"fixed":"0.9.9","introduced":"0"}],"component":"dulwich","cve_ids":["CVE-2015-0838"],"ecosystem":"PyPI","epss":0.03379,"exploited":false,"fixed_versions":["0.9.9"],"ghsa_id":"GHSA-vjjf-3rvg-gv3v","id":"tcs_01M5KG6PM6N9C4G3AVB3D83HS9","modified_at":"2026-06-10T17:01:12.353047752Z","published_at":"2015-03-31T14:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2015-35","http://www.debian.org/security/2015/dsa-3206","https://lists.launchpad.net/dulwich-users/msg00829.html","https://github.com/advisories/GHSA-vjjf-3rvg-gv3v"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2015-35","url":"https://osv.dev/vulnerability/PYSEC-2015-35"}],"summary":"Buffer overflow in the C implementation of the apply_delta function in _pack.c in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a crafted pack file."}