{"action":"Upgrade django to 1.4.18 or later.","affected":[{"fixed":"1.4.18","introduced":"0"},{"fixed":"1.6.10","introduced":"1.5"},{"fixed":"1.7.3","introduced":"1.7"}],"component":"django","cve_ids":["CVE-2015-0220"],"ecosystem":"PyPI","epss":0.03053,"exploited":false,"fixed_versions":["1.4.18","1.6.10","1.7.3"],"ghsa_id":"GHSA-gv98-g628-m9x5","id":"tcs_01M5KG6QXANT26WVA89DW69TPV","modified_at":"2026-06-10T17:01:01.511638044Z","published_at":"2015-01-16T16:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2015-5","http://secunia.com/advisories/62285","https://www.djangoproject.com/weblog/2015/jan/13/security/","http://secunia.com/advisories/62309","http://ubuntu.com/usn/usn-2469-1","http://secunia.com/advisories/62718","http://advisories.mageia.org/MGASA-2015-0026.html","http://www.mandriva.com/security/advisories?name=MDVSA-2015:036","http://www.mandriva.com/security/advisories?name=MDVSA-2015:109","http://lists.opensuse.org/opensuse-updates/2015-04/msg00001.html","http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148485.html","http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148608.html","http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html","https://github.com/advisories/GHSA-gv98-g628-m9x5"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2015-5","url":"https://osv.dev/vulnerability/PYSEC-2015-5"}],"summary":"The django.util.http.is_safe_url function in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 does not properly handle leading whitespaces, which allows remote attackers to conduct cr"}