{"action":"Upgrade django to 1.4.20 or later.","affected":[{"fixed":"1.4.20","introduced":"0"},{"fixed":"1.6.11","introduced":"1.5"},{"fixed":"1.7.7","introduced":"1.7"},{"fixed":"1.8c1","introduced":"1.8a0"}],"component":"django","cve_ids":["CVE-2015-2317"],"ecosystem":"PyPI","epss":0.04968,"exploited":false,"fixed_versions":["1.4.20","1.6.11","1.7.7","1.8c1"],"ghsa_id":"GHSA-7fq8-4pv5-5w5c","id":"tcs_01M5KG6RGVJZ5771GT902Y36TS","modified_at":"2026-06-10T17:01:00.424905034Z","published_at":"2015-03-25T14:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2015-9","http://ubuntu.com/usn/usn-2539-1","https://www.djangoproject.com/weblog/2015/mar/18/security-releases/","http://www.debian.org/security/2015/dsa-3204","http://lists.opensuse.org/opensuse-updates/2015-04/msg00001.html","http://www.mandriva.com/security/advisories?name=MDVSA-2015:195","http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155421.html","http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html","http://lists.fedoraproject.org/pipermail/package-announce/2015-June/160263.html","http://www.securityfocus.com/bid/73319","http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html","https://github.com/advisories/GHSA-7fq8-4pv5-5w5c"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2015-9","url":"https://osv.dev/vulnerability/PYSEC-2015-9"}],"summary":"The utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not properly validate URLs, which allows remote attackers to co"}