{"action":"Upgrade keystonemiddleware to 1.5.4 or later.","affected":[{"fixed":"1.5.4","introduced":"0"},{"fixed":"2.3.3","introduced":"1.6.0"}],"component":"keystonemiddleware","cve_ids":["CVE-2015-7546"],"ecosystem":"PyPI","epss":0.01997,"exploited":false,"fixed_versions":["1.5.4","2.3.3"],"ghsa_id":"GHSA-8c4w-v65p-jvcv","id":"tcs_01M5KG6TKHCZRR2NTRTSFRKWR5","modified_at":"2026-07-13T16:42:52.889269796Z","published_at":"2016-02-03T18:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2016-20","https://bugs.launchpad.net/keystone/+bug/1490804","https://wiki.openstack.org/wiki/OSSN/OSSN-0062","https://security.openstack.org/ossa/OSSA-2016-005.html","http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html","http://www.securityfocus.com/bid/80498","https://github.com/advisories/GHSA-8c4w-v65p-jvcv"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2016-20","url":"https://osv.dev/vulnerability/PYSEC-2016-20"}],"summary":"The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty be"}