{"action":"Upgrade mercurial to 3.7.3 or later.","affected":[{"fixed":"3.7.3","introduced":"0"}],"component":"mercurial","cve_ids":["CVE-2016-3630"],"ecosystem":"PyPI","epss":0.04854,"exploited":false,"fixed_versions":["3.7.3"],"ghsa_id":"GHSA-9vjf-jjcq-3gh7","id":"tcs_01M5KG6WCTRNAA2NC4GK1G42GJ","modified_at":"2026-06-10T17:01:49.107894004Z","published_at":"2016-04-13T16:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2016-29","http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00018.html","http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00017.html","http://lists.fedoraproject.org/pipermail/package-announce/2016-April/181505.html","https://selenic.com/repo/hg-stable/rev/b6ed2505d6cf","https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.7.3_.282016-3-29.29","http://lists.fedoraproject.org/pipermail/package-announce/2016-April/181542.html","http://www.debian.org/security/2016/dsa-3542","http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00016.html","https://selenic.com/repo/hg-stable/rev/b9714d958e89","http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00043.html","http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html","https://security.gentoo.org/glsa/201612-19","https://github.com/advisories/GHSA-9vjf-jjcq-3gh7"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2016-29","url":"https://osv.dev/vulnerability/PYSEC-2016-29"},{"source":"nvd","source_id":"CVE-2016-3630","url":"https://nvd.nist.gov/vuln/detail/CVE-2016-3630"}],"summary":"The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b)"}