{"action":"Upgrade moin to 1.9.9 or later.","affected":[{"fixed":"1.9.9","introduced":"0"}],"component":"moin","cve_ids":["CVE-2016-7146"],"ecosystem":"PyPI","epss":0.01196,"exploited":false,"fixed_versions":["1.9.9"],"ghsa_id":"GHSA-fj26-q4vh-85f6","id":"tcs_01M5KG6WQB98VAZBDENM4P66AQ","modified_at":"2026-06-10T17:02:23.145043371Z","published_at":"2016-11-10T17:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2016-30","https://www.curesec.com/blog/article/blog/MoinMoin-198-XSS-175.html","http://www.securityfocus.com/bid/94259","http://www.ubuntu.com/usn/USN-3137-1","http://www.debian.org/security/2016/dsa-3715","https://github.com/advisories/GHSA-fj26-q4vh-85f6"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"PYSEC-2016-30","url":"https://osv.dev/vulnerability/PYSEC-2016-30"},{"source":"nvd","source_id":"CVE-2016-7146","url":"https://nvd.nist.gov/vuln/detail/CVE-2016-7146"}],"summary":"MoinMoin 1.9.8 allows remote attackers to conduct \"JavaScript injection\" attacks by using the \"page creation or crafted URL\" approach, related to a \"Cross Site Scripting (XSS)\" issue affecting the act"}