{"action":"Upgrade pyspark to 2.1.2 or later.","affected":[{"fixed":"2.1.2","introduced":"0"}],"component":"pyspark","cve_ids":["CVE-2017-12612"],"ecosystem":"PyPI","epss":0.00734,"exploited":false,"fixed_versions":["2.1.2"],"ghsa_id":"GHSA-8rhc-48pp-52gr","id":"tcs_01M5KG73KMN5EFY7H9Z908GA1X","modified_at":"2024-11-25T22:42:11.091237Z","published_at":"2017-09-13T16:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-147","https://mail-archives.apache.org/mod_mbox/spark-dev/201709.mbox/%3CCAEccTyy-1yYuhdNgkBUg0sr9NeaZSrBKkBePdTNZbxXZNTAR-g%40mail.gmail.com%3E","http://www.securityfocus.com/bid/100823"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"PYSEC-2017-147","url":"https://osv.dev/vulnerability/PYSEC-2017-147"}],"summary":"In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially"}