{"action":"Upgrade moin to 1.9.8 or later.","affected":[{"fixed":"1.9.8","introduced":"0"}],"component":"moin","cve_ids":["CVE-2016-9119"],"ecosystem":"PyPI","epss":0.01464,"exploited":false,"fixed_versions":["1.9.8"],"ghsa_id":"GHSA-5fq5-pfv8-mrfv","id":"tcs_01M5KG75N458PKYA25TTFHGCBV","modified_at":"2026-06-10T17:02:23.297557787Z","published_at":"2017-01-30T22:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-20","https://moinmo.in/SecurityFixes","http://www.ubuntu.com/usn/USN-3137-1","http://www.debian.org/security/2016/dsa-3715","http://www.securityfocus.com/bid/94501","https://github.com/advisories/GHSA-5fq5-pfv8-mrfv"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2017-20","url":"https://osv.dev/vulnerability/PYSEC-2017-20"}],"summary":"Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors."}