{"action":"Upgrade pyanyapi to 0.6.1 or later.","affected":[{"fixed":"0.6.1","introduced":"0"}],"component":"pyanyapi","cve_ids":["CVE-2017-16616"],"ecosystem":"PyPI","epss":0.0362,"exploited":false,"fixed_versions":["0.6.1"],"ghsa_id":"GHSA-vg8g-jpm9-jh8r","id":"tcs_01M5KG7651XBRQY2R8T627FWKT","modified_at":"2023-11-08T03:59:13.122220Z","published_at":"2017-11-08T03:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-23","https://pypi.python.org/pypi/pyanyapi/0.6.1","https://github.com/Stranger6667/pyanyapi/releases/tag/0.6.1","https://github.com/Stranger6667/pyanyapi/issues/41","https://joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16616-yamlparser-in-pyanyapi/","https://github.com/advisories/GHSA-vg8g-jpm9-jh8r"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2017-23","url":"https://osv.dev/vulnerability/PYSEC-2017-23"},{"source":"nvd","source_id":"CVE-2017-16616","url":"https://nvd.nist.gov/vuln/detail/CVE-2017-16616"}],"summary":"An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting"}