{"action":"Upgrade ipython to 3.2.0 or later.","affected":[{"fixed":"3.2.0","introduced":"3.0.0"}],"component":"ipython","cve_ids":["CVE-2015-4706"],"ecosystem":"PyPI","epss":0.021,"exploited":false,"fixed_versions":["3.2.0"],"ghsa_id":"GHSA-q326-jhw3-699g","id":"tcs_01M5KG7AFFD3D6N5S44T2EMN9V","modified_at":"2023-11-08T03:57:55.658486Z","published_at":"2017-09-21T14:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-45","https://ipython.org/ipython-doc/3/whatsnew/version3.html","https://github.com/ipython/ipython/commit/c2078a53543ed502efd968649fee1125e0eb549c","https://github.com/ipython/ipython/commit/7222bd53ad089a65fd610fab4626f9d0ab47dfce","https://bugzilla.redhat.com/show_bug.cgi?id=1235688","http://www.openwall.com/lists/oss-security/2015/06/22/7","http://www.securityfocus.com/bid/75328","https://github.com/advisories/GHSA-q326-jhw3-699g"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2017-45","url":"https://osv.dev/vulnerability/PYSEC-2017-45"}],"summary":"Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/contents path."}