{"action":"Upgrade openpgp to 4.2.0 or later.","affected":[{"fixed":"4.2.0","introduced":"0"}],"component":"openpgp","cve_ids":["CVE-2019-9153"],"ecosystem":"npm","epss":0.02013,"exploited":false,"fixed_versions":["4.2.0"],"ghsa_id":"GHSA-qwqc-28w3-fww6","id":"tcs_01M5KG7CYP70HJWADKPTPFQKYV","modified_at":"2023-11-08T04:01:46.612755Z","published_at":"2019-08-23T21:42:20Z","references":["https://osv.dev/vulnerability/GHSA-qwqc-28w3-fww6","https://nvd.nist.gov/vuln/detail/CVE-2019-9153","https://github.com/openpgpjs/openpgpjs/pull/797/commits/327d3e5392a6f59a4270569d200c7f7a2bfc4cbc","https://github.com/openpgpjs/openpgpjs/pull/816","https://github.com/openpgpjs/openpgpjs/releases/tag/v4.2.0","https://sec-consult.com/en/blog/advisories/multiple-vulnerabilities-in-openpgp-js","https://snyk.io/vuln/SNYK-JS-OPENPGP-460248","https://www.bsi.bund.de/SharedDocs/Downloads/EN/BSI/Publications/Studies/Mailvelope_Extensions/Mailvelope_Extensions_pdf.html#download=1","https://www.npmjs.com/advisories/1160","http://packetstormsecurity.com/files/154191/OpenPGP.js-4.2.0-Signature-Bypass-Invalid-Curve-Attack.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-qwqc-28w3-fww6","url":"https://osv.dev/vulnerability/GHSA-qwqc-28w3-fww6"}],"summary":"Message Signature Bypass in openpgp"}