{"action":"Upgrade cfscrape to 1.8.0 or later.","affected":[{"fixed":"1.8.0","introduced":"1.6.6"}],"component":"cfscrape","cve_ids":["CVE-2017-7235"],"ecosystem":"PyPI","epss":0.01548,"exploited":false,"fixed_versions":["1.8.0"],"ghsa_id":"GHSA-5mc5-5j6c-qmf9","id":"tcs_01M5KG7F15NNRWAV7TVSD3GGW5","modified_at":"2023-11-08T03:59:24.135930Z","published_at":"2017-03-23T04:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-7","https://github.com/Anorov/cloudflare-scrape/releases/tag/1.8.0","https://github.com/Anorov/cloudflare-scrape/issues/97","http://www.securityfocus.com/bid/97191","https://github.com/advisories/GHSA-5mc5-5j6c-qmf9"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2017-7","url":"https://osv.dev/vulnerability/PYSEC-2017-7"}],"summary":"An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. T"}