{"action":"Upgrade github.com/containerd/containerd/v2 to 2.0.4 or later.","affected":[{"fixed":"2.0.4","introduced":"0"}],"component":"github.com/containerd/containerd/v2","cve_ids":["CVE-2024-40635"],"ecosystem":"Go","epss":0.00304,"exploited":false,"fixed_versions":["2.0.4"],"ghsa_id":"GHSA-265r-hfxg-fhmg","id":"tcs_01M5KG7FAF0ZGKC1TRBVWN91QV","modified_at":"2026-02-04T03:50:47.304274Z","published_at":"2025-03-18T18:14:48Z","references":["https://osv.dev/vulnerability/GO-2025-3528","https://github.com/containerd/containerd/security/advisories/GHSA-265r-hfxg-fhmg","https://github.com/containerd/containerd/commit/05044ec0a9a75232cad458027ca83437aae3f4da","https://github.com/containerd/containerd/commit/1a43cb6a1035441f9aca8f5666a9b3ef9e70ab20","https://github.com/containerd/containerd/commit/cf158e884cfe4812a6c371b59e4ea9bc4c46e51a"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"GO-2025-3528#Go/github.com/containerd/containerd/v2","url":"https://osv.dev/vulnerability/GO-2025-3528"}],"summary":"containerd has an integer overflow in User ID handling in github.com/containerd/containerd"}