{"action":"Upgrade mercurial to 4.3 or later.","affected":[{"fixed":"4.3","introduced":"0"}],"component":"mercurial","cve_ids":["CVE-2017-1000115"],"ecosystem":"PyPI","epss":0.04815,"exploited":false,"fixed_versions":["4.3"],"ghsa_id":"GHSA-hvr9-wr9p-grgr","id":"tcs_01M5KG7JHD2NJ65YGGJG7HWSZ3","modified_at":"2026-06-10T17:01:22.920699996Z","published_at":"2017-10-05T01:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-88","https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.3_.2F_4.3.1_.282017-08-10.29","https://security.gentoo.org/glsa/201709-18","http://www.securityfocus.com/bid/100290","http://www.debian.org/security/2017/dsa-3963","https://access.redhat.com/errata/RHSA-2017:2489","https://github.com/advisories/GHSA-hvr9-wr9p-grgr"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2017-88","url":"https://osv.dev/vulnerability/PYSEC-2017-88"}],"summary":"Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository"}