{"action":"Upgrade mercurial to 4.4.1 or later.","affected":[{"fixed":"4.4.1","introduced":"0"}],"component":"mercurial","cve_ids":["CVE-2017-17458"],"ecosystem":"PyPI","epss":0.06331,"exploited":false,"fixed_versions":["4.4.1"],"ghsa_id":"GHSA-6v56-cpg6-3rpx","id":"tcs_01M5KG7K09B8N95846FJZJR7FJ","modified_at":"2026-06-10T17:01:22.982575802Z","published_at":"2017-12-07T18:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-90","https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.4.1_.282017-11-07.29","https://www.mercurial-scm.org/pipermail/mercurial-devel/2017-November/107333.html","https://bz.mercurial-scm.org/show_bug.cgi?id=5730","https://confluence.atlassian.com/sourcetreekb/sourcetree-security-advisory-2018-01-24-942834324.html","https://lists.debian.org/debian-lts-announce/2017/12/msg00027.html","http://www.securityfocus.com/bid/102926","https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html","https://lists.debian.org/debian-lts-announce/2018/07/msg00041.html","https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html","https://github.com/advisories/GHSA-6v56-cpg6-3rpx"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2017-90","url":"https://osv.dev/vulnerability/PYSEC-2017-90"}],"summary":"In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repo"}