{"action":"Upgrade priority to 1.2.0 or later.","affected":[{"fixed":"1.2.0","introduced":"0"}],"component":"priority","cve_ids":["CVE-2016-6580"],"ecosystem":"PyPI","epss":0.01807,"exploited":false,"fixed_versions":["1.2.0"],"ghsa_id":"GHSA-h3q4-6j7f-r24c","id":"tcs_01M5KG7KQNVA731KVTXCSXZD1V","modified_at":"2026-06-10T17:01:38.249933537Z","published_at":"2017-01-10T15:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-93","https://python-hyper.org/priority/en/latest/security/CVE-2016-6580.html","http://www.securityfocus.com/bid/92311","https://github.com/advisories/GHSA-h3q4-6j7f-r24c"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2017-93","url":"https://osv.dev/vulnerability/PYSEC-2017-93"}],"summary":"A HTTP/2 implementation built using any version of the Python priority library prior to version 1.2.0 could be targeted by a malicious peer by having that peer assign priority information for every po"}