{"action":"Upgrade tlslite to 0.4.9 or later.","affected":[{"fixed":"0.4.9","introduced":"0"}],"component":"tlslite","cve_ids":["CVE-2015-3220"],"ecosystem":"PyPI","epss":0.0323,"exploited":false,"fixed_versions":["0.4.9"],"ghsa_id":"GHSA-4749-p7rx-8jjj","id":"tcs_01M5KG7M6CDA9QM3N0MY5PCN8P","modified_at":"2026-06-10T17:02:44.556425643Z","published_at":"2017-06-13T16:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-96","https://github.com/trevp/tlslite/commit/aca8d4f898b436ff6754e1a9ab96cae976c8a853","https://bugzilla.redhat.com/show_bug.cgi?id=1254215","https://groups.google.com/forum/#!topic/tlslite-dev/MoWE7B0A4iU","https://github.com/advisories/GHSA-4749-p7rx-8jjj"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2017-96","url":"https://osv.dev/vulnerability/PYSEC-2017-96"}],"summary":"The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash)."}