{"action":"Upgrade urllib3 to 1.18.1 or later.","affected":[{"fixed":"1.18.1","introduced":"1.17"}],"component":"urllib3","cve_ids":["CVE-2016-9015"],"ecosystem":"PyPI","epss":0.00754,"exploited":false,"fixed_versions":["1.18.1"],"ghsa_id":"GHSA-v4w5-p2hg-8fh6","id":"tcs_01M5KG7MG151A5PM7CRMA2QRWK","modified_at":"2026-06-10T17:02:48.350726400Z","published_at":"2017-01-11T16:59:00Z","references":["https://osv.dev/vulnerability/PYSEC-2017-98","http://www.securityfocus.com/bid/93941","http://www.openwall.com/lists/oss-security/2016/10/27/6","https://github.com/advisories/GHSA-v4w5-p2hg-8fh6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2017-98","url":"https://osv.dev/vulnerability/PYSEC-2017-98"}],"summary":"Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not correctly validate TLS certificates. This places users of the li"}