{"action":"Upgrade knowledge-repo to 0.7.5 or later.","affected":[{"fixed":"0.7.5","introduced":"0"}],"component":"knowledge-repo","cve_ids":["CVE-2018-12104"],"ecosystem":"PyPI","epss":0.01279,"exploited":false,"fixed_versions":["0.7.5"],"ghsa_id":"GHSA-xmw7-848p-p95w","id":"tcs_01M5KG7RCCS4B95P3V0C7G7G7W","modified_at":"2026-06-10T17:01:49.071479008Z","published_at":"2018-06-17T20:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-116","https://github.com/airbnb/knowledge-repo/issues/431","http://www.securityfocus.com/bid/104487","https://pypi.org/project/knowledge-repo","https://nvd.nist.gov/vuln/detail/CVE-2018-12104","https://github.com/advisories/GHSA-xmw7-848p-p95w"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-116","url":"https://osv.dev/vulnerability/PYSEC-2018-116"}],"summary":"Cross-site scripting (XSS) vulnerability in Airbnb Knowledge Repo 0.7.4 allows remote attackers to inject arbitrary web scripts or HTML via the post comments functionality, as demonstrated by the post"}