{"action":"Upgrade openclaw to 2026.4.23 or later.","affected":[{"fixed":"2026.4.23","introduced":"0"}],"component":"openclaw","cve_ids":["CVE-2026-45004"],"ecosystem":"npm","epss":0.00144,"exploited":false,"fixed_versions":["2026.4.23"],"ghsa_id":"GHSA-r39h-4c2p-3jxp","id":"tcs_01M5KG7RE1B8WA305CFBWH9YKD","modified_at":"2026-05-19T16:11:27.270216Z","published_at":"2026-05-05T18:43:44Z","references":["https://osv.dev/vulnerability/GHSA-r39h-4c2p-3jxp","https://github.com/openclaw/openclaw/security/advisories/GHSA-r39h-4c2p-3jxp","https://nvd.nist.gov/vuln/detail/CVE-2026-45004","https://github.com/openclaw/openclaw/commit/993781e6e6eaf50f033cfc3e3bf4f47059740707","https://github.com/openclaw/openclaw","https://www.vulncheck.com/advisories/openclaw-arbitrary-code-execution-via-setup-api-js-in-current-working-directory"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-r39h-4c2p-3jxp","url":"https://osv.dev/vulnerability/GHSA-r39h-4c2p-3jxp"}],"summary":"OpenClaw vulnerable to arbitrary code execution via attacker-controlled setup-api.js loaded from cwd during env-key resolution"}