{"action":"Upgrade pg-query to 0.28 or later.","affected":[{"fixed":"0.28","introduced":"0"}],"component":"pg-query","cve_ids":["CVE-2018-18482"],"ecosystem":"PyPI","epss":0.0116,"exploited":false,"fixed_versions":["0.28"],"ghsa_id":"GHSA-vm3q-58wm-2r2x","id":"tcs_01M5KG7T43G0MXD526F13EPM6Y","modified_at":"2026-07-07T11:56:13.031518594Z","published_at":"2018-10-18T18:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-154","https://github.com/lfittl/libpg_query/issues/49"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2018-154","url":"https://osv.dev/vulnerability/PYSEC-2018-154"}],"summary":"An issue was discovered in libpg_query 10-1.0.2. There is a memory leak in pg_query_raw_parse in pg_query_parse.c, which might lead to a denial of service."}