{"action":"Upgrade salt to 2017.7.8 or later.","affected":[{"fixed":"2017.7.8","introduced":"0"},{"fixed":"2018.3.3","introduced":"2018.3.0"}],"component":"salt","cve_ids":["CVE-2018-15751"],"ecosystem":"PyPI","epss":0.04902,"exploited":false,"fixed_versions":["2018.3.3","2017.7.8"],"ghsa_id":"GHSA-x549-r7m8-gv63","id":"tcs_01M5KG7XAHD57HG0QDZG6FZVT5","modified_at":"2026-06-10T17:02:37.944895808Z","published_at":"2018-10-24T22:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-30","https://groups.google.com/d/msg/salt-users/L9xqcJ0UXxs/qgDj42obBQAJ","https://groups.google.com/d/msg/salt-users/dimVF7rpphY/jn3Xv3MbBQAJ","https://docs.saltstack.com/en/latest/topics/releases/2018.3.3.html","https://docs.saltstack.com/en/2017.7/topics/releases/2017.7.8.html","http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00070.html","https://lists.debian.org/debian-lts-announce/2020/07/msg00024.html","https://usn.ubuntu.com/4459-1/","https://github.com/advisories/GHSA-x549-r7m8-gv63"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-30","url":"https://osv.dev/vulnerability/PYSEC-2018-30"}],"summary":"SaltStack Salt before 2017.7.8 and 2018.3.x before 2018.3.3 allow remote attackers to bypass authentication and execute arbitrary commands via salt-api(netapi)."}