{"action":"Upgrade tlslite-ng to 0.7.4 or later.","affected":[{"fixed":"0.7.4","introduced":"0"}],"component":"tlslite-ng","cve_ids":["CVE-2018-1000159"],"ecosystem":"PyPI","epss":0.00772,"exploited":false,"fixed_versions":["0.7.4"],"ghsa_id":"GHSA-cwh5-3cw7-4286","id":"tcs_01M5KG7XF2WTN416528KCPN2MA","modified_at":"2023-11-08T03:59:36.197516Z","published_at":"2018-04-18T19:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-31","https://github.com/tomato42/tlslite-ng/pull/234","https://github.com/advisories/GHSA-cwh5-3cw7-4286"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-31","url":"https://osv.dev/vulnerability/PYSEC-2018-31"}],"summary":"tlslite-ng version 0.7.3 and earlier, since commit d7b288316bca7bcdd082e6ccff5491e241305233 contains a CWE-354: Improper Validation of Integrity Check Value vulnerability in TLS implementation, tlslit"}