{"action":"Upgrade ansible to 2.1.4.0 or later.","affected":[{"fixed":"2.1.4.0","introduced":"0"},{"fixed":"2.2.1.0","introduced":"2.2.0.0"}],"component":"ansible","cve_ids":["CVE-2016-9587"],"ecosystem":"PyPI","epss":0.1714,"exploited":false,"fixed_versions":["2.1.4.0","2.2.1.0"],"ghsa_id":"GHSA-m956-frf4-m2wr","id":"tcs_01M5KG7Z5109F0GW0NY0GHNBE7","modified_at":"2023-11-08T03:58:38.355952Z","published_at":"2018-04-24T16:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-39","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9587","https://www.exploit-db.com/exploits/41013/","https://security.gentoo.org/glsa/201701-77","https://access.redhat.com/errata/RHSA-2017:1685","https://access.redhat.com/errata/RHSA-2017:0515","https://access.redhat.com/errata/RHSA-2017:0448","http://www.securityfocus.com/bid/95352","http://rhn.redhat.com/errata/RHSA-2017-0260.html","http://rhn.redhat.com/errata/RHSA-2017-0195.html","https://github.com/advisories/GHSA-m956-frf4-m2wr"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-39","url":"https://osv.dev/vulnerability/PYSEC-2018-39"}],"summary":"Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed b"}