{"action":"Upgrade ansible to 2.4.6.0 or later.","affected":[{"fixed":"2.4.6.0","introduced":"2.4"},{"fixed":"2.5.6","introduced":"2.5"},{"fixed":"2.6.1","introduced":"2.6"}],"component":"ansible","cve_ids":["CVE-2018-10875"],"ecosystem":"PyPI","epss":0.00592,"exploited":false,"fixed_versions":["2.5.6","2.4.6.0","2.6.1"],"ghsa_id":"GHSA-fc4h-467w-46rh","id":"tcs_01M5KG7ZWQCV3HC4QH4BH29BDT","modified_at":"2026-06-10T17:00:17.175190234Z","published_at":"2018-07-13T22:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-43","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10875","https://access.redhat.com/errata/RHSA-2018:2166","https://access.redhat.com/errata/RHSA-2018:2152","https://access.redhat.com/errata/RHSA-2018:2151","https://access.redhat.com/errata/RHSA-2018:2150","https://access.redhat.com/errata/RHSA-2018:2321","http://www.securitytracker.com/id/1041396","https://access.redhat.com/errata/RHSA-2018:2585","https://access.redhat.com/errata/RHBA-2018:3788","https://access.redhat.com/errata/RHSA-2019:0054","https://www.debian.org/security/2019/dsa-4396","http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html","https://usn.ubuntu.com/4072-1/","https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html","https://github.com/advisories/GHSA-fc4h-467w-46rh"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-43","url":"https://osv.dev/vulnerability/PYSEC-2018-43"}],"summary":"A flaw was found in ansible. ansible.cfg is read from the current working directory which can be altered to make it point to a plugin or a module path under the control of an attacker, thus allowing t"}