{"action":"Upgrade pysaml2 to 4.5.0 or later.","affected":[{"fixed":"4.5.0","introduced":"0"}],"component":"pysaml2","cve_ids":["CVE-2017-1000433"],"ecosystem":"PyPI","epss":0.02541,"exploited":false,"fixed_versions":["4.5.0"],"ghsa_id":"GHSA-924m-4pmx-c67h","id":"tcs_01M5KG80P3GAK2PT7N17WGB6HJ","modified_at":"2023-11-08T03:58:46.488294Z","published_at":"2018-01-02T23:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-48","https://github.com/rohe/pysaml2/issues/451","https://security.gentoo.org/glsa/201801-11","https://lists.debian.org/debian-lts-announce/2018/07/msg00000.html","https://lists.debian.org/debian-lts-announce/2021/02/msg00038.html","https://github.com/advisories/GHSA-924m-4pmx-c67h"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-48","url":"https://osv.dev/vulnerability/PYSEC-2018-48"}],"summary":"pysaml2 version 4.4.0 and older accept any password when run with python optimizations enabled. This allows attackers to log in as any user without knowing their password."}