{"action":"Upgrade flask to 0.12.3 or later.","affected":[{"fixed":"0.12.3","introduced":"0"}],"component":"flask","cve_ids":["CVE-2018-1000656"],"ecosystem":"PyPI","epss":0.03855,"exploited":false,"fixed_versions":["0.12.3"],"ghsa_id":"GHSA-562c-5r94-xh97","id":"tcs_01M5KG83ZZ3T0D3D81H8AY9TAP","modified_at":"2023-11-08T03:59:39.887416Z","published_at":"2018-08-20T19:31:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-66","https://github.com/pallets/flask/releases/tag/0.12.3","https://github.com/pallets/flask/pull/2691","https://security.netapp.com/advisory/ntap-20190221-0001/","https://lists.debian.org/debian-lts-announce/2019/08/msg00025.html","https://usn.ubuntu.com/4378-1/","https://github.com/advisories/GHSA-562c-5r94-xh97"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-66","url":"https://osv.dev/vulnerability/PYSEC-2018-66"}],"summary":"The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of servic"}