{"action":"Upgrade uwsgi to 2.0.17 or later.","affected":[{"fixed":"2.0.17","introduced":"0"}],"component":"uwsgi","cve_ids":["CVE-2018-7490"],"ecosystem":"PyPI","epss":0.69423,"exploited":false,"fixed_versions":["2.0.17"],"ghsa_id":"GHSA-h2vm-c85r-5vh5","id":"tcs_01M5KG86ATZAWJFNY2R14AG2EF","modified_at":"2026-06-10T17:02:45.841314903Z","published_at":"2018-02-26T22:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-78","https://uwsgi-docs.readthedocs.io/en/latest/Changelog-2.0.17.html","https://www.exploit-db.com/exploits/44223/","https://www.debian.org/security/2018/dsa-4142","https://github.com/advisories/GHSA-h2vm-c85r-5vh5"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-78","url":"https://osv.dev/vulnerability/PYSEC-2018-78"}],"summary":"uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal."}