{"action":"Upgrade websockets to 5.0 or later.","affected":[{"fixed":"5.0","introduced":"0"}],"component":"websockets","cve_ids":["CVE-2018-1000518"],"ecosystem":"PyPI","epss":0.01805,"exploited":false,"fixed_versions":["5.0"],"ghsa_id":"GHSA-6g87-ff9q-v847","id":"tcs_01M5KG86FT7SX1RKH0V6TR1PA5","modified_at":"2023-11-08T03:59:38.649508Z","published_at":"2018-06-26T16:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-79","https://github.com/aaugustin/websockets/pull/407","https://github.com/advisories/GHSA-6g87-ff9q-v847"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2018-79","url":"https://osv.dev/vulnerability/PYSEC-2018-79"},{"source":"nvd","source_id":"CVE-2018-1000518","url":"https://nvd.nist.gov/vuln/detail/CVE-2018-1000518"}],"summary":"aaugustin websockets version 4 contains a CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Servers and clients, unless configured with compression=None that c"}