{"action":"Upgrade mercurial to 4.5.1 or later.","affected":[{"fixed":"4.5.1","introduced":"0"}],"component":"mercurial","cve_ids":["CVE-2018-1000132"],"ecosystem":"PyPI","epss":0.02617,"exploited":false,"fixed_versions":["4.5.1"],"ghsa_id":"GHSA-4mr4-7vjv-9hm6","id":"tcs_01M5KG87XWWWM82FGTRVZKZV34","modified_at":"2026-06-10T17:01:23.646538700Z","published_at":"2018-03-14T13:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2018-87","https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.5.1_.2F_4.5.2_.282018-03-06.29","https://lists.debian.org/debian-lts-announce/2018/03/msg00034.html","https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html","https://access.redhat.com/errata/RHSA-2019:2276","https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html","https://github.com/advisories/GHSA-4mr4-7vjv-9hm6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2018-87","url":"https://osv.dev/vulnerability/PYSEC-2018-87"}],"summary":"Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via n"}