{"action":"Upgrade rpyc to 4.1.2 or later.","affected":[{"fixed":"4.1.2","introduced":"4.1.0"}],"component":"rpyc","cve_ids":["CVE-2019-16328"],"ecosystem":"PyPI","epss":0.13049,"exploited":false,"fixed_versions":["4.1.2"],"ghsa_id":"GHSA-9ggp-4jpr-7ppj","id":"tcs_01M5KG8DT3F4048P40N6V5ZTTA","modified_at":"2023-11-08T04:01:17.495506Z","published_at":"2019-10-03T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-118","https://rpyc.readthedocs.io/en/latest/docs/security.html","https://github.com/tomerfiliba/rpyc","http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00046.html","http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00004.html","https://github.com/advisories/GHSA-9ggp-4jpr-7ppj","https://github.com/advisories/GHSA-pj4g-4488-wmxm"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-118","url":"https://osv.dev/vulnerability/PYSEC-2019-118"}],"summary":"In RPyC 4.1.x through 4.1.1, a remote attacker can dynamically modify object attributes to construct a remote procedure call that executes code for an RPyC service with default configuration settings."}