{"action":"Upgrade scapy to 2.4.1 or later.","affected":[{"fixed":"2.4.1","introduced":"0"}],"component":"scapy","cve_ids":["CVE-2019-1010142"],"ecosystem":"PyPI","epss":0.02791,"exploited":false,"fixed_versions":["2.4.1"],"ghsa_id":"GHSA-mpf2-q34c-fc6j","id":"tcs_01M5KG8E8M7Y4SXWGDCBQS296B","modified_at":"2023-11-08T04:00:40.784299Z","published_at":"2019-07-19T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-120","https://github.com/secdev/scapy/pull/1409/files#diff-441eff981e466959968111fc6314fe93L1058","https://github.com/secdev/scapy/pull/1409","https://www.imperva.com/blog/scapy-sploit-python-network-tool-is-vulnerable-to-denial-of-service-dos-attack-cve-pending/","http://www.securityfocus.com/bid/106674","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T46XW4S5BCA3VV3JT3C5Q6LBEXSIACLN/","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/42NRPMC3NS2QVFNIXYP6WV2T3LMLLY7E/","https://github.com/advisories/GHSA-mpf2-q34c-fc6j"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-120","url":"https://osv.dev/vulnerability/PYSEC-2019-120"}],"summary":"scapy 2.4.0 is affected by: Denial of Service. The impact is: infinite loop, resource consumption and program unresponsive. The component is: _RADIUSAttrPacketListField.getfield(self..). The attack ve"}