{"action":"Upgrade typed-ast to 1.3.2 or later.","affected":[{"fixed":"1.3.2","introduced":"0"}],"component":"typed-ast","cve_ids":["CVE-2019-19275"],"ecosystem":"PyPI","epss":0.03283,"exploited":false,"fixed_versions":["1.3.2"],"ghsa_id":"GHSA-7xxv-wpxj-mx5v","id":"tcs_01M5KG8GAW105NBDMR8J7EM70P","modified_at":"2023-11-08T04:01:28.229049Z","published_at":"2019-11-26T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-131","https://github.com/python/typed_ast/commit/156afcb26c198e162504a57caddfe0acd9ed7dce","https://github.com/python/typed_ast/commit/dc317ac9cff859aa84eeabe03fb5004982545b3b","https://github.com/python/cpython/commit/dcfcd146f8e6fc5c2fc16a4c192a0c5f5ca8c53c","https://github.com/python/cpython/commit/a4d78362397fc3bced6ea80fbc7b5f4827aec55e","https://bugs.python.org/issue36495","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LG5H4Q6LFVRX7SFXLBEJMNQFI4T5SCEA/","https://github.com/advisories/GHSA-7xxv-wpxj-mx5v"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-131","url":"https://osv.dev/vulnerability/PYSEC-2019-131"}],"summary":"typed_ast 1.3.0 and 1.3.1 has an ast_for_arguments out-of-bounds read. An attacker with the ability to cause a Python interpreter to parse Python source (but not necessarily execute it) may be able to"}