{"action":"Upgrade waitress to 1.4.1 or later.","affected":[{"fixed":"1.4.1","introduced":"0"}],"component":"waitress","cve_ids":["CVE-2019-16789"],"ecosystem":"PyPI","epss":0.02587,"exploited":false,"fixed_versions":["1.4.1"],"ghsa_id":"GHSA-968f-66r5-5v74","id":"tcs_01M5KG8HKTEVSF2R5CGRJGAJHA","modified_at":"2023-11-08T04:01:21.767656Z","published_at":"2019-12-26T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-138","https://github.com/Pylons/waitress/commit/11d9e138125ad46e951027184b13242a3c1de017","https://github.com/github/advisory-review/pull/14604","https://docs.pylonsproject.org/projects/waitress/en/latest/#security-fixes","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GVDHR2DNKCNQ7YQXISJ45NT4IQDX3LJ7/","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LYEOTGWJZVKPRXX2HBNVIYWCX73QYPM5/","https://access.redhat.com/errata/RHSA-2020:0720","https://github.com/advisories/GHSA-968f-66r5-5v74"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-138","url":"https://osv.dev/vulnerability/PYSEC-2019-138"}],"summary":"In Waitress through version 1.4.0, if a proxy server is used in front of waitress, an invalid request may be sent by an attacker that bypasses the front-end and is parsed differently by waitress leadi"}