{"action":"Upgrade ansible to 2.5.14 or later.","affected":[{"fixed":"2.5.14","introduced":"2.5.0"},{"fixed":"2.6.11","introduced":"2.6.0"},{"fixed":"2.7.5","introduced":"2.7.0"}],"component":"ansible","cve_ids":["CVE-2018-16876"],"ecosystem":"PyPI","epss":0.02483,"exploited":false,"fixed_versions":["2.5.14","2.6.11","2.7.5"],"ghsa_id":"GHSA-j569-fghw-f9rx","id":"tcs_01M5KG8J72PF6ZT8NQZ6TZ34KR","modified_at":"2026-06-10T17:00:18.594019081Z","published_at":"2019-01-03T15:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-141","https://github.com/ansible/ansible/pull/49569","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16876","https://access.redhat.com/errata/RHSA-2018:3838","https://access.redhat.com/errata/RHSA-2018:3837","https://access.redhat.com/errata/RHSA-2018:3836","https://access.redhat.com/errata/RHSA-2018:3835","http://www.securityfocus.com/bid/106225","https://www.debian.org/security/2019/dsa-4396","https://access.redhat.com/errata/RHSA-2019:0564","https://access.redhat.com/errata/RHSA-2019:0590","http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html","https://usn.ubuntu.com/4072-1/","http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html","https://github.com/advisories/GHSA-j569-fghw-f9rx"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-141","url":"https://osv.dev/vulnerability/PYSEC-2019-141"}],"summary":"ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data."}