{"action":"Upgrade ansible to 2.6.19 or later.","affected":[{"fixed":"2.6.19","introduced":"2.6.0"},{"fixed":"2.7.13","introduced":"2.7.0"},{"fixed":"2.8.4","introduced":"2.8.0"}],"component":"ansible","cve_ids":["CVE-2019-10206"],"ecosystem":"PyPI","epss":0.01503,"exploited":false,"fixed_versions":["2.6.19","2.7.13","2.8.4"],"ghsa_id":"GHSA-cqmr-rcpr-cxh3","id":"tcs_01M5KG8JNNQVKGS3P0H64ZBFN7","modified_at":"2026-06-10T17:00:15.947216023Z","published_at":"2019-11-22T13:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-145","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html","https://github.com/advisories/GHSA-cqmr-rcpr-cxh3"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2019-145","url":"https://osv.dev/vulnerability/PYSEC-2019-145"},{"source":"nvd","source_id":"CVE-2019-10206","url":"https://nvd.nist.gov/vuln/detail/CVE-2019-10206"}],"summary":"ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain"}