{"action":"Upgrade @backstage/plugin-kubernetes-backend to 0.21.8 or later.","affected":[{"fixed":"0.21.8","introduced":"0"}],"component":"@backstage/plugin-kubernetes-backend","cve_ids":["CVE-2026-106563"],"ecosystem":"npm","epss":0.00225,"exploited":false,"fixed_versions":["0.21.8"],"ghsa_id":"GHSA-r9ph-3637-55px","id":"tcs_01M5KG8N83CJARGKJ2WT9DY0BN","modified_at":"2026-10-07T18:15:11.761928207Z","published_at":"2026-10-07T18:02:37Z","references":["https://osv.dev/vulnerability/GHSA-r9ph-3637-55px","https://github.com/backstage/backstage/security/advisories/GHSA-r9ph-3637-55px","https://nvd.nist.gov/vuln/detail/CVE-2026-106563","https://github.com/backstage/backstage/commit/2d5d3e77d630455d6d48cfa8f31fd3c126fd6f29","https://github.com/backstage/backstage","https://github.com/backstage/backstage/releases/tag/v1.54.1"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-r9ph-3637-55px","url":"https://osv.dev/vulnerability/GHSA-r9ph-3637-55px"}],"summary":"Backstage: Improper entity validation in deprecated Kubernetes services endpoint"}