{"action":"Upgrade notebook to 5.5.0 or later.","affected":[{"fixed":"5.5.0","introduced":"0"}],"component":"notebook","cve_ids":["CVE-2018-21030"],"ecosystem":"PyPI","epss":0.01443,"exploited":false,"fixed_versions":["5.5.0"],"ghsa_id":"GHSA-jqwc-jm56-wcwj","id":"tcs_01M5KG8NBZ0KA758NX6VDZ8HYD","modified_at":"2023-11-08T04:00:14.113021Z","published_at":"2019-10-31T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-157","https://github.com/jupyter/notebook/releases/tag/5.5.0","https://github.com/jupyter/notebook/pull/3341","https://lists.debian.org/debian-lts-announce/2020/11/msg00033.html","https://github.com/advisories/GHSA-jqwc-jm56-wcwj"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2019-157","url":"https://osv.dev/vulnerability/PYSEC-2019-157"},{"source":"nvd","source_id":"CVE-2018-21030","url":"https://nvd.nist.gov/vuln/detail/CVE-2018-21030"}],"summary":"Jupyter Notebook before 5.5.0 does not use a CSP header to treat served files as belonging to a separate origin. Thus, for example, an XSS payload can be placed in an SVG document."}