{"action":"Upgrade ansible to 2.8.1 or later.","affected":[{"fixed":"2.8.1","introduced":"2.0"}],"component":"ansible","cve_ids":["CVE-2019-14858"],"ecosystem":"PyPI","epss":0.00424,"exploited":false,"fixed_versions":["2.8.1"],"ghsa_id":"GHSA-h653-95qw-h2mp","id":"tcs_01M5KG8R6SSMM7ZVA7GB8KGGDS","modified_at":"2026-06-10T17:00:18.580471794Z","published_at":"2019-10-14T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-171","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14858","https://access.redhat.com/errata/RHSA-2019:3207","https://access.redhat.com/errata/RHSA-2019:3201","https://access.redhat.com/errata/RHSA-2019:3202","https://access.redhat.com/errata/RHSA-2019:3203","https://access.redhat.com/errata/RHSA-2020:0756","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html","https://github.com/advisories/GHSA-h653-95qw-h2mp"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-171","url":"https://osv.dev/vulnerability/PYSEC-2019-171"}],"summary":"A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to"}