{"action":"Upgrade firebase-tools to 13.6.0 or later.","affected":[{"fixed":"13.6.0","introduced":"0"}],"component":"firebase-tools","cve_ids":["CVE-2024-4128"],"ecosystem":"npm","epss":0.0013,"exploited":false,"fixed_versions":["13.6.0"],"ghsa_id":"GHSA-rcm2-22f3-pqv3","id":"tcs_01M5KG8SMKD1TZGWMC4HYZRCXH","modified_at":"2025-07-22T21:41:39Z","published_at":"2024-05-02T15:30:35Z","references":["https://osv.dev/vulnerability/GHSA-rcm2-22f3-pqv3","https://nvd.nist.gov/vuln/detail/CVE-2024-4128","https://github.com/firebase/firebase-tools/pull/6944","https://github.com/firebase/firebase-tools/commit/068a2b08dc308c7ab4b569617f5fc8821237e3a0","https://github.com/firebase/firebase-tools"],"severity":{"label":"low","score":2.6},"sources":[{"source":"osv","source_id":"GHSA-rcm2-22f3-pqv3","url":"https://osv.dev/vulnerability/GHSA-rcm2-22f3-pqv3"}],"summary":"Firebase vulnerable to CRSF attack"}