{"action":"Upgrade nova to 17.0.12 or later.","affected":[{"fixed":"17.0.12","introduced":"0"},{"fixed":"18.2.2","introduced":"18.0.0"},{"fixed":"19.0.2","introduced":"19.0.0"}],"component":"nova","cve_ids":["CVE-2019-14433"],"ecosystem":"PyPI","epss":0.01943,"exploited":false,"fixed_versions":["19.0.2","17.0.12","18.2.2"],"ghsa_id":"GHSA-pg64-r7rr-phv8","id":"tcs_01M5KG8W7J48FY2C61TS0YB43P","modified_at":"2026-06-10T17:02:26.170256860Z","published_at":"2019-08-09T19:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-191","http://www.openwall.com/lists/oss-security/2019/08/06/6","https://security.openstack.org/ossa/OSSA-2019-003.html","https://launchpad.net/bugs/1837877","https://usn.ubuntu.com/4104-1/","https://access.redhat.com/errata/RHSA-2019:2622","https://access.redhat.com/errata/RHSA-2019:2631","https://access.redhat.com/errata/RHSA-2019:2652","https://github.com/advisories/GHSA-pg64-r7rr-phv8"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-191","url":"https://osv.dev/vulnerability/PYSEC-2019-191"}],"summary":"An issue was discovered in OpenStack Nova before 17.0.12, 18.x before 18.2.2, and 19.x before 19.0.2. If an API request from an authenticated user ends in a fault condition due to an external exceptio"}