{"action":"Upgrade ansible to 2.6.18 or later.","affected":[{"fixed":"2.6.18","introduced":"0"},{"fixed":"2.7.12","introduced":"2.7.0"},{"fixed":"2.8.2","introduced":"2.8.0"}],"component":"ansible","cve_ids":["CVE-2019-10156"],"ecosystem":"PyPI","epss":0.01774,"exploited":false,"fixed_versions":["2.6.18","2.7.12","2.8.2"],"ghsa_id":"GHSA-grgm-pph5-j5h7","id":"tcs_01M5KG8XM2E4XJFMAM4N3TWJ7S","modified_at":"2023-11-08T04:00:41.754182Z","published_at":"2019-07-30T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-2","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156","https://github.com/ansible/ansible/pull/57188","https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html","https://access.redhat.com/errata/RHSA-2019:3744","https://access.redhat.com/errata/RHSA-2019:3789","https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html","https://github.com/advisories/GHSA-grgm-pph5-j5h7"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-2","url":"https://osv.dev/vulnerability/PYSEC-2019-2"}],"summary":"A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitut"}