{"action":"Upgrade tensorflow to 1.7.1 or later.","affected":[{"fixed":"1.7.1","introduced":"0"}],"component":"tensorflow","cve_ids":["CVE-2018-7577"],"ecosystem":"PyPI","epss":0.00517,"exploited":false,"fixed_versions":["1.7.1"],"ghsa_id":"GHSA-qx2v-j445-g354","id":"tcs_01M5KG8ZD2X3QNPQ5XPYZM1ZAY","modified_at":"2023-11-08T04:00:23.185405Z","published_at":"2019-04-24T17:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-207","https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-005.md","https://github.com/advisories/GHSA-qx2v-j445-g354"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"PYSEC-2019-207","url":"https://osv.dev/vulnerability/PYSEC-2019-207"},{"source":"nvd","source_id":"CVE-2018-7577","url":"https://nvd.nist.gov/vuln/detail/CVE-2018-7577"}],"summary":"Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from other parts of process memory."}