{"action":"Upgrade homeassistant to 0.67.0 or later.","affected":[{"fixed":"0.67.0","introduced":"0"}],"component":"homeassistant","cve_ids":["CVE-2018-21019"],"ecosystem":"PyPI","epss":0.01691,"exploited":false,"fixed_versions":["0.67.0"],"ghsa_id":"GHSA-mh78-8f49-vjg3","id":"tcs_01M5KG92DY566Z3MGQN4Y169EB","modified_at":"2026-06-10T17:01:51.682479991Z","published_at":"2019-09-23T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-221","https://github.com/home-assistant/home-assistant/pull/13836","https://github.com/home-assistant/home-assistant/releases/tag/0.67.0","https://github.com/advisories/GHSA-mh78-8f49-vjg3"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2019-221","url":"https://osv.dev/vulnerability/PYSEC-2019-221"}],"summary":"Home Assistant before 0.67.0 was vulnerable to an information disclosure that allowed an unauthenticated attacker to read the application's error log via components/api.py."}