{"action":"Upgrade tensorflow-gpu to 1.7.1 or later.","affected":[{"fixed":"1.7.1","introduced":"0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2018-7577"],"ecosystem":"PyPI","epss":0.00523,"exploited":false,"fixed_versions":["1.7.1"],"ghsa_id":"GHSA-qx2v-j445-g354","id":"tcs_01M5KG94B4C5WQ97WX1AY7A4N1","modified_at":"2026-06-10T17:02:43.244352860Z","published_at":"2019-04-24T17:29:00Z","references":["https://osv.dev/vulnerability/PYSEC-2019-232","https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-005.md","https://github.com/advisories/GHSA-qx2v-j445-g354"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"PYSEC-2019-232","url":"https://osv.dev/vulnerability/PYSEC-2019-232"},{"source":"nvd","source_id":"CVE-2018-7577","url":"https://nvd.nist.gov/vuln/detail/CVE-2018-7577"}],"summary":"Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from other parts of process memory."}