{"action":"Upgrade mongodb-client-encryption to 1.2.1 or later.","affected":[{"fixed":"1.2.1","introduced":"1.2.0"}],"component":"mongodb-client-encryption","cve_ids":["CVE-2021-20327"],"ecosystem":"npm","epss":0.00202,"exploited":false,"fixed_versions":["1.2.1"],"ghsa_id":"GHSA-rjmf-p882-645m","id":"tcs_01M5KG9ACS5K436NRVGT9TQMZ3","modified_at":"2024-09-16T22:04:44Z","published_at":"2021-04-12T18:51:17Z","references":["https://osv.dev/vulnerability/GHSA-rjmf-p882-645m","https://nvd.nist.gov/vuln/detail/CVE-2021-20327","https://github.com/mongodb/libmongocrypt/commit/76365515ff8754b9f705e56428dd0d7efa7f541b","https://github.com/mongodb/libmongocrypt","https://jira.mongodb.org/browse/NODE-3125","https://www.npmjs.com/advisories/1660"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"GHSA-rjmf-p882-645m","url":"https://osv.dev/vulnerability/GHSA-rjmf-p882-645m"}],"summary":"mongodb-client-encryption vulnerable to Improper Certificate Validation"}